using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?:[^()]|(?R))*\)";
string input = @"Quiz: (Find all text that) outside of the outmost balanced parenthesis. (Be careful since) there might (be ((nested)) ones!) :) (async () => await console.log(1))()) You can do it! ()()(())():((1)((((((2)((3)))))))It would be even better the text is consecutive (and no more unneccessary (capturing groups!))() 2 * (1 + 3) = 8(eight) :( Did you do it ? (no) yes";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}