re = /\b(?:(?:0?[0-9]?[0-9]|1?[0-9]?[0-9]|2[0-4][0-9]|25[0-5])\.??\b){4}/m
str = 'Should Match:
204.131.100.104
255.255.005.055
192.168.10.1
172.16.1.1
10.10.10.1
1.2.3.4
255.255.255.255
001.02.3.004
123.145.254.189:8080
1.2.3.4-4.3.20.1
4.3.2.1.9.8.7.6
Shouldnt match:
255.256.255.255
172.999.2.3
this is a string1.2.3.4
this is another 1.2.3.4string
144.109.279.255
v1.2.3.4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end