re = /{{\s+([<\w\s"@(){}\/=>]+)}}/
str = '@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end