$re = '/^\$(\d{1,3}(,\d{3})*|(\d+))(.\d{2})?$/m';
$str = '$308.40';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);