import re
regex = re.compile(r"^([^http|s|ftp|www|\/\/|])*", flags=re.MULTILINE)
test_str = ("xxxx.xxxx.xxxx\n"
"ftp://www.xxzx.com/xxx.aspx\n"
"https://www.xxzx.com/xxx.aspx\n"
"http://xxxx.com\n"
"https://xxzx.com/xxx.aspx\n"
"http://www.xxxx.com\n"
"//www.xxxx.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")