import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(>.*?)\\QStyle\\E([^=][^<]*)";
final String string = "<div><p style=\"text-align:left;\">Style: <span style=\"float:right;\">Casual</span></p></div><div><p style=\"text-align:left;\">Color: <span style=\"float:right;\">Navy Blue</span></p></div><div><p style=\"text-align:left;\">Pattern Type: <span style=\"float:right;\">Plain</span></p></div><div><p style=\"text-align:left;\">Neckline: <span style=\"float:right;\">Round Neck</span></p></div><div><p style=\"text-align:left;\">Length: <span style=\"float:right;\">Long</span></p></div><div><p style=\"text-align:left;\">Type: <span style=\"float:right;\">A Line</span></p></div><div><p style=\"text-align:left;\">Details: <span style=\"float:right;\">Pearls</span></p></div><div><p style=\"text-align:left;\">Details: <span style=\"float:right;\">Frill</span></p></div><div><p style=\"text-align:left;\">Details: <span style=\"float:right;\">Beaded</span></p></div><div><p style=\"text-align:left;\">Details: <span style=\"float:right;\">Pocket</span></p></div><div><p style=\"text-align:left;\">Sleeve Length: <span style=\"float:right;\">Half Sleeve</span></p></div><div><p style=\"text-align:left;\">Season: <span style=\"float:right;\">Spring/Fall</span></p></div><div><p style=\"text-align:left;\">Composition: <span style=\"float:right;\">75% Cotton</span></p></div><div><p style=\"text-align:left;\">Composition: <span style=\"float:right;\">Denim</span></p></div><div><p style=\"text-align:left;\">Composition: <span style=\"float:right;\">25% Polyester</span></p></div><div><p style=\"text-align:left;\">Fabric: <span style=\"float:right;\">Non-Stretch</span></p></div><div><p style=\"text-align:left;\">Waist Line: <span style=\"float:right;\">Natural</span></p></div><br /><table border=\"1\"><thead><tr><th>size</th><th>Shoulder </th><th>Bust </th><th>Waist Size </th><th>Hip Size </th><th>Sleeve Length </th><th>Length </th><th>Bicep Length </th><th>Cuff </th></tr></thead><tbody><tr><td>XS</td><td> 38 cm</td><td> 91 cm</td><td> 90 cm</td><td> 101 cm</td><td> 39 cm</td><td> 139 cm</td><td> 30 cm</td><td> 25 cm</td></tr><tr><td>S</td><td> 39 cm</td><td> 95 cm</td><td> 94 cm</td><td> 105 cm</td><td> 40 cm</td><td> 140 cm</td><td> 31 cm</td><td> 26 cm</td></tr><tr><td>M</td><td> 40 cm</td><td> 99 cm</td><td> 98 cm</td><td> 109 cm</td><td> 41 cm</td><td> 141 cm</td><td> 32 cm</td><td> 27 cm</td></tr><tr><td>L</td><td> 41 cm</td><td> 103 cm</td><td> 102 cm</td><td> 113 cm</td><td> 42 cm</td><td> 142 cm</td><td> 33 cm</td><td> 28 cm</td></tr></tbody></table>";
final String subst = "$1MODIFIED_COLOR$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}