$re = '/(.+?)\s*-\s*(\d+)$/m';
$str = 'Winston-Salem-Time-Trials - 2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);