re = /Tableau Server (?<Service>[^']+)'\s*\(?(?<PD>\d+)?\)?\s+(?:is|status\s+is)\s+(?<Status>[\w\s]+)\./m
str = '2018-05-25 02:21:30.270 -0500_EXACT_10.218.108.14:RTEEPK08_:pid=12466_0x4364712fuser=request=_ RTEEPK08:
Status: DEGRADED
\'Tableau Server Data Engine\' (7653) is running.
\'Tableau Server Coordination Service 0\' (7633) is running.
\'Tableau Server Search and Browse 0\' (2542) is running.
\'Tableau Server Tabadmin Service 0\' (25262) is running.
\'Tableau Server Gateway\' (252564) is running.
\'Tableau Server Cluster Controller\' is stopped.
\'Tableau Server Repository\' status is not available.
\'Tableau Server File Store\' status is not available.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end