package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{{\n(.+)\n.+}}`)
var str = `@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}