# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?: # 采用非捕获括号进行分组(非必要不使用捕获型括号)
(`{3,}) # 捕获组,匹配三个及以上反引号,并进行捕获
[\s\S]*? # 采用非贪婪匹配(必须),匹配0到n次空白或非空白字符(任意字符)
(?:(?:\1`*)|\Z) # 引用,引用了之前的捕获组,若之前捕获了5个反引号,则在此必须匹配5个以上反引号,若开头三个以上反引号,后面没有比开头更多的反引号,则后面都是代码块
) # 结束第一个分支
| # 或符号
(?: # 同上,采用非捕获型括号
(~{3,}) # 同上,匹配三个及以上波浪号并进行捕获
[\s\S]*? # 同上,非贪婪匹配来匹配0到n次空白或非空白字符
(?:(?:\2~*)|\Z) # 引用,引用了之前的捕获组
) # 结束第二个分支
| # 或符号
(?: # 同上,采用非捕获型括号
(?<= # 肯定型逆序环视,左侧文本必须满足条件才可以匹配
(?:^\n)|(?:^\A) # 上一行必须只有一个回车(以回车符号开头)或没有上一行
) # 结束环视
(?: # 采用非捕获型括号分组
(?:\s{4,}?|\t+?)[^\n]*(?:\n|$) # 匹配四个及以上空格或一个以上制表符开启的一行
)+ # 上面的子组匹配1次到n次
) # 结束第三个分支
"""
test_str = (" this is a code block\n"
" \n"
"// 1. 匹配四个空格导出的代码块\n\n"
" functino(asfd)\n"
" safdsadf\n"
" safsadf\n"
" safdsdaf\n"
" \n\n\n"
"// 2. 匹配三个反引号所引出的代码块\n"
"```\n"
" func function(){\n"
" }\n"
"```\n\n"
"这里是一些文本\n"
"……\n"
"………………\n\n"
"``` python\n"
" print(\"hello\")\n"
"```\n\n"
"// 3.如果四个空格之前的一行不是回车独占一行,则不会导出代码块(符合Markdown约定)\n"
" function(asfd)\n"
" safdsadf\n"
" safsadf\n"
" safdsdaf\n"
" safd\n"
" \n\n"
"// 4. 匹配三个波浪号导出的代码块\n\n"
"~~~\n"
" fmt.println(123)\n"
"~~~\n\n"
"// 5. 匹配前后四个及以上反引号导出的代码块\n"
"````\n"
"aaa\n"
"```\n"
"````\n\n"
"这里是一些文本……\n\n"
"`````\n"
" print(\"this is a code block\")\n"
"`````\n\n"
"`````\n"
" print(\"this is a code block\")\n"
"````````````````````````\n"
"// 6. 匹配前后四个及以上波浪号导出的代码块\n"
"~~~~\n"
"aaa\n"
"~~~\n"
"~~~~\n\n"
"这里是一些文本……\n\n"
"~~~~~~\n"
" print(\"this is a code block\")\n"
"~~~~~~\n\n"
"~~~~~~\n"
" print(\"this is a code block\")\n"
"~~~~~~~~~~~~~~~~~~~~~~~~\n\n"
"// 7. 只有开头,没有结尾的,都算代码块\n"
"```\n"
"asdfasdf\n"
"asdfasdf\n"
"asdfasdf\n"
"asdfasdf\n"
"asdfasdf\n"
"asdf\n"
"没有结尾,这里也算代码块")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.