# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(<img)(?=((?:[^>\"']|\"[^\"]*\"|'[^']*')*?\ssrc\s*=\s*(['\"])\/mycms\/~\/media\/)([a-f0-9]{32})(\.ashx\3(?:\"[\S\s]*?\"|'[\S\s]*?'|[^>]*?)+>))\s+(?:\"[\S\s]*?\"|'[\S\s]*?'|[^>]*?)+>"
test_str = ("<a hello world href=\"/mycms/~/link.aspx?_id=D9423CEFED254610A5DC6B096A297E17&_z=z\" class>\n"
"...\n"
"</a>\n\n"
"<img hello world src=\"/mycms/~/media/B1FB91AC357347BD84913D56B8791D03.ashx\" alt=\"\" width=\"690\" height=\"202\" />\n\n")
subst = "$1$2key{$4}$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.