import re
regex = re.compile(r"^([^.]*\.[^.]*)\.", flags=re.IGNORECASE)
test_str = " Some.."
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)