import re
regex = re.compile(r"Jude ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjud ?\d{1,3}:\d{1,3}(-\d{1,3})?\b|\bjd ?\d{1,3}:\d{1,3}(-\d{1,3})?\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("jude1:1\n"
"jude 1:1\n"
"jude1:1-2\n"
"judges1:1-2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")