# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*|\"(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])*\")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])"
test_str = ("Valid email addresses\n"
"simple@example.com\n"
"\"user@name\"@example.com\n"
"very.common@example.com\n"
"disposable.style.email.with+symbol@example.com\n"
"other.email-with-hyphen@example.com\n"
"fully-qualified-domain@example.com\n"
"user.name+tag+sorting@example.com (may go to user.name@example.com inbox depending on mail server)\n"
"x@example.com (one-letter local-part)\n"
"example-indeed@strange-example.com\n"
"test/test@test.com (slashes are a printable character, and allowed)\n"
"admin@mailserver1 (local domain name with no TLD, although ICANN highly discourages dotless email addresses[10])\n"
"example@s.example (see the List of Internet top-level domains)\n"
"\" \"@example.org (space between the quotes)\n"
"\"john..doe\"@example.org (quoted double dot)\n"
"mailhost!username@example.org (bangified host route used for uucp mailers)\n"
"user%example.com@example.org (% escaped mail route to user@example.com via example.org)\n"
"user-@example.org (local part ending with non-alphanumeric character from the list of allowed printable characters)\n"
"postmaster@[123.123.123.123] (IP addresses are allowed instead of domains when in square brackets, but strongly discouraged)\n"
"postmaster@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334] (IPv6 uses a different syntax)\n\n"
"Invalid email addresses\n"
"Abc.example.com (no @ character)\n"
"A@b@c@example.com (only one @ is allowed outside quotation marks)\n"
"a\"b(c)d,e:f;gi[j\\k]l@example.com (none of the special characters in this local-part are allowed outside quotation marks)\n"
"just\"not\"right@example.com (quoted strings must be dot separated or the only element making up the local-part)\n"
"this is\"not\\allowed@example.com (spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)\n"
"this\\ still\\\"not\\\\allowed@example.com (even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)\n"
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com (local-part is longer than 64 characters)\n"
"i_like_underscore@but_its_not_allowed_in_this_part.example.com (Underscore is not allowed in domain part)\n"
"QA[icon]CHOCOLATE[icon]@test.com (icon characters)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.