$re = '/\b(?!п?ос[л|к][а|о]р?бляе?т?ь?л?)\w*бля\w*|(\w*бляд\w*)|(\w*ху[й|и|е|ё|я|]\w*)|\b(хули)\b|([е|ё]{1,}пт[а|и|е|о]?\b)|(п[и|е|ё]зд\w*)|(пид[а|о|е]р\w*)|(пид[е|а|о]р)|(пидр?[\w]{1,}\b)|(гандон\w*)|\b(?!н[е|ё])(?!гр[е|ё])(\w*[е|ё]б[а|о|и|н]\w*)|(?!\w)(еб[е|ё|а|у|н]\w*)|(\w*[у|е|за]{1,2}[е|ё]б)|\b(?!\w)\s([ё|е]б)\s|(еб[е|ё]\w*)/simu';
$str = 'бля блять блядь блядина выблядок сракоблять сракоблядь оскарблять оскорблять блядосрака бляцкий блятский блядский блцк ослаблять ослабляет оскарбляет ослоблял ослаблял осбаляет оскарблять оскарблядь ослоблядь ослоблядит послаблять
хуй хуило хуйло хуево хуёво хуже хуев хуи хуевая хуёвая хуёвый хуятина хули хулио
ебать заебал уебок уебище уебан уёбан уёбок ёб нёбо гёрб захлёб уебался заебал уебал ебать ёпта ёпт епта епт епти ёпти ёпто ебучие еб ебнутый ебется ебётся долбаёб долбаеб ебал ёбнутый ебанат ебанклаус грёб в захлёб заебался
пизда пизданулся пиздец пиздос пиздатый пизд пиздюк
пидр пидор пидар пидер пидарас пидорас пидерас пидераст пидараст пидораст пидрила пидрило
гандон гандонина';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);