import re
regex = re.compile(r" (?=[^ ]+$)", flags=re.MULTILINE)
test_str = "Les hommes-grenouilles dans la rivière."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)