$re = '/\'results\':\s+\{\'(?<feature>[^\']+)\':\s+\{\'result\':\s+\'(?<result>[^\']+)/m';
$str = '{\'requestId\': \'cibilcreditscore/6a373431-014c-4531-8332-746c5033e85c\', \'entity\': \'CIBIL_CHECK\', \'results\': {\'BALANCE_MAX1_10000_SEC_EXT_WOE_INT\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'BALANCE_MEAN1_10000_APPROVED_AMT_MEAN1_10000_POS_EXT_WOE_INT\': {\'result\': \'-9999.0\', \'version\': \'v4\'}, \'CIBIL_ACC_DTCLOSED_FIRSTCLEND\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'CIBIL_ACC_LIMIT_OPEN_REV\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'CIBIL_CC_AMTOVERDUE_SUM\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'CIBIL_DPD_LAST_5DPD\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'CIBIL_DPD_MAX_13_18_NUM\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'CIBIL_DPD_RATE_10DPD_3M\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'CIBIL_ENQ_CNT_90D\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'CIBIL_ENQ_LN_NOHC_CNT_24M\': {\'result\': \'2\', \'version\': \'v4\'}, \'CIBIL_ENQ_NOHC_TMSNC_LAST\': {\'result\': \'0\', \'version\': \'v4\'}, \'CIBIL_NOHC_INSTL_PAID_NORMALLY_60M\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'CIBIL_P_OCCUPATION\': {\'result\': \'N/A\', \'version\': \'v4\'}, \'CIBIL_SCORE\': {\'result\': \'171.0\', \'version\': \'v4\'}, \'DPD_NUM_ADJ_MAX1_10000_MEAN1_10000_SEC_EXT_WOE_INT\': {\'result\': \'-9999.0\', \'version\': \'v4\'}, \'DPD_NUM_ADJ_MEAN1_10000_EXT_WOE_INT\': {\'result\': \'-9999.0\', \'version\': \'v4\'}, \'FLAG_Cons_Loan_SUM1_EXT\': {\'result\': \'2\', \'version\': \'v4\'}, \'FLAG_ENQ_ANY_SUM1_90_EXT\': {\'result\': \'2\', \'version\': \'v4\'}, \'TS_ENQ_F_D\': {\'result\': \'0\', \'version\': \'v4\'}, \'TS_OPEN_DT_F_SEC_CLS_D_EXT\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'TS_OPEN_DT_F_SEC_STAT_UNIF_CLSD_D_EXT_WOE_INT\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'cbActiveEmi\': {\'result\': \'-9999\', \'version\': \'v3\'}, \'cbDisposableIncome\': {\'result\': \'-9999\', \'version\': \'v2\'}, \'cbDpdMax18mNum\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'cbDpdRate1Dpd12m\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'cbEnqCnt90d\': {\'result\': \'-9999\', \'version\': \'v4\'}, \'cbEstimatedIncome\': {\'result\': \'-9999\', \'version\': \'v3\'}, \'ciAccVehClosedCnt\': {\'result\': \'-9999\', \'version\': \'v2\'}, \'ciAmountMax1180Mean1180\': {\'result\': \'1.606425702811245\', \'version\': \'v6\'}, \'ciAmountMean110000\': {\'result\': \'62250.0\', \'version\': \'v6\'}, \'ciAmtOverdue2BalSum90\': {\'result\': \'-9999.0\', \'version\': \'v7\'}, \'ciAmtOverdue2FaOvdRtExt\': {\'result\': \'-9999\', \'version\': \'v2\'},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);