$re = '/(?=((?:ab.){2}))/m';
$str = 'abab1ab2ab3bcaab4ab5ab6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);