$re = '/(?<=^FOO=)\w*$/m';
$str = 'BAR=baz
FOO=fur
FOA=fab
FOO=foo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);