import re
regex = re.compile(r"^https?:\/\/(?:(?:youtu\.be\/)|(?:(?:www\.)?youtube\.com\/(?:(?:watch\?(?:[^&]+&)?vi?=)|(?:vi?\/)|(?:shorts\/))))([a-zA-Z0-9_-]{11,})", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("https://youtu.be/NLqAF9hrVbY\n"
"http://www.youtube.com/v/NLqAF9hrVbY?fs=1&hl=en_US\n"
"https://www.youtube.com/watch?v=NLqAF9hrVbY\n"
"http://www.youtube.com/watch?v=JYArUl0TzhA&feature=featured\n"
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"http://youtu.be/6dwqZw0j_jY\n"
"http://www.youtube.com/watch?v=6dwqZw0j_jY&feature=youtu.be \n"
"http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"http://www.youtube.com/watch?v=peFZbP64dsU\n"
"http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player \n"
"http://youtu.be/afa-5HQHiAs\n"
"http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
"http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://youtube.com/watch?feature=youtube_gdata_player&vi=dQw4w9WgXcQ\n"
"http://youtube.com/watch?feature=youtube_gdata_player&v=dQw4w9WgXcQ\n"
"https://youtube.com/shorts/TjBH4bJr7SM?feature=share")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")