import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(!?){0}([+]){1}([998]){3}\\s([7-9]){1}([0-9]){1}\\s([0-9]){3}\\s([0-9]){2}\\s([0-9]){2}$";
final String string = "+998 99 477 55 55\n"
+ "998 33 665 55 55\n"
+ "+997 66 123 12 12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}