$re = '/(?<!\w)\w{3,8}(?!\w)/m';
$str = 'words with length three to eight';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);