re = /(?<!\d)((?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:\.(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}),(\d{1,5})(?!\d)/m
str = '1.33.3.146,9001,,fwioetwg4utghw4ignc,Fast Running Stable Valid,447,reject,1-65535,0
999.99.99.7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end