re = /(?<=5;)(?P<date>\d{8})|(?<=;3;)(?P<value>\d+(?:\.\d+)?)/m
str = ';2;4;2;5;20181201;3;102;5;20191201;3;101.000000;5;20201201;3;100.000000;5;20211201;3;100.000000;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end