re = /(?<before>.+)<table>(?<inside>.+)<\/table>(?<after>.+)/m
str = 'текст перед таблицей <table>содержимое таблицы</table> и после'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end