re = /\bFOLDER\/[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}\.txt\b/m
str = 'FOLDER/0101a8ef-db10-405a-a1d2-6bebdeb17625.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end