re = /[0-9a-fA-F]{8}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{4}-[0-9a-fA-F]{12}/
str = '48ca6756-0035-4896-80f4-70b655061310'
# Print the match result
str.match(re) do |match|
puts match.to_s
end