re = /^foo\/(?(?=login)(login)|(.*?)(set|get))$/m
str = 'foo/
foo/login
foo/login/get
foo/sadas/set
foo/sadasf/asd
foo/blabla/get'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end