re = /(\S)(\S+)\1(?=\s|$)/m
str = '8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result