$re = '/(?<=>)\s*(?=<)|(?<=>)\n*([^<]+)/i';
$str = '<div class="user" ><?= $username ?></div>
<table>
<tr>
<td>Cell 1</td>
<td>Cell 2</td>
</tr>
</table>
<span>Lorem ipsum <b>dolor</b> sit amet</span>
Lorem ipsum dolor sit amet <a href="www.example.com">Lorem</a>
Dolor site amet at date <?php echo date(\'Y-m-d\'); ?> example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);