// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^https?:\/\/((w{3}\.)|(w{0}))\w+\.[a-z]{2,6}\/([\S]+)").unwrap();
let string = "https://www.tiki.vn/dien-thoai-may-tinh-bang/c1789?src=mega-menu ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}