package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?:[^()]|\b\([^()]*\))*\)`)
var str = `([Valor][Corr][Fat]: 6M UC x Viz. Lógicos IN('3','6')) AND (((SUM_RevisionAnomalia_UltRevision_1M = 1) AND (CANT_ConsumoFact_UltRevision_1M > 1)) OR ((SUM_RevisionNoAnomalia_UltRevision_1M + 1) AND (CANT_ConsumoFact_UltRevision_1M BETWEEN 1 - 2))) OR (SUM_RevisionNoAnomalia_UltRevision_1M <= 1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}