re = /\([^()]*(?:\b\([^()]*\)[^()]*)*\)/
str = '([Valor][Corr][Fat]: 6M UC x Viz. Lógicos IN(\'3\',\'6\')) AND (((SUM_RevisionAnomalia_UltRevision_1M = 1) AND (CANT_ConsumoFact_UltRevision_1M > 1)) OR ((SUM_RevisionNoAnomalia_UltRevision_1M + 1) AND (CANT_ConsumoFact_UltRevision_1M BETWEEN 1 - 2))) OR (SUM_RevisionNoAnomalia_UltRevision_1M <= 1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end