$re = '/\b(?<!#)[a-zA-Z]+/m';
$str = 'Makeupby Antonia #makeup #makeupartist #makeupdolls #abhcosmetics';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);