package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^;]*;\s*([^=]*)=.*$`)
var str = `name1=value1; name2=value2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}