import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?'State'Idle|Run|Hold|Home|Alarm|Check|Door)(?:,MPos:(?'MX'[0-9\\.]*),(?'MY'[0-9\\.]*),(?'MZ'[0-9\\.]*))?(?:,WPos:(?'WX'[0-9\\.]*),(?'WY'[0-9\\.]*),(?'WZ'[0-9\\.]*))?(?:,Buf:(?'Buf'[0-9]*))?(?:,RX:(?'RX'[0-9]*))?(?:,Ln:(?'L'[0-9]*))?(?:,F:(?'F'[0-9\\.]*))?(?:,Lim:(?'Lim'[0-1]*))?(?:,Ctl:(?'Ctl'[0-1]*))?>";
final String string = "<Idle,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Buf:8,Ln:49,Lim:1001>\n"
+ "<Run,MPos:4.028,0.000,0.000,WPos:4.028,0.000,0.000,RX:25,F:34.4>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}