#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<= )test\b|\btest(?= )"
Local $sString = "This is a test." & @CRLF & _
"The testing was good." & @CRLF & _
"The tester was bad." & @CRLF & _
"package.test.com" & @CRLF & _
"skkg@test.com" & @CRLF & _
"Regex-test-is tough" & @CRLF & _
""rm/_HOST@DEV.HADOOP.R1-CORE.R1.TEST.NET"" & @CRLF & _
"/Users/dattem/Desktop/DevCenter/test/ssl/" & @CRLF & _
"The test is today." & @CRLF & _
"Name -test one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")