package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+)`)
var str = `A
B
C`
var substitution = "$1_$1_suffix"
fmt.Println(re.ReplaceAllString(str, substitution))
}