import re
regex = re.compile(r"Integral of Qr over area magnitude of patch ([\w.-]+\[\d+])\s*=\s*(-?\d*\.?\d+)", flags=re.MULTILINE)
test_str = ("//some text\n\n"
"Integral of Qr over area magnitude of patch B1_TE16_B1_TE4[0] = -1073.40295735\n\n"
"//some more text\n\n"
"Integral of Qr over area magnitude of patch B1_TE16_B1_TE11[1] = 1099.13456362\n\n"
"//some more text\n\n"
"Integral of Qr over area magnitude of patch B1_TE16_B1_TE13[2] = 1025.13456362")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")