$re = '/^(?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?((?:[^:\n?=ֿ#\/]+|\/(?=[^\s\/])[^:\n?=ֿ#\/]*)*)/m';
$str = 'domain.com/home/ = domain.com/home/
domain.com/home?param=value = domain.com/home
http://www.test.com/a/b/c/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);