import re
regex = re.compile((r"(?i).*cc.*(cor.*ang.*|heart.*|icd.*|pace.*|coronary.*|cardi.*|aortic.*|lhc.*|.rhc.*|dual.*lead.*|cabg.*|trans.*echo.*)\n"))
test_str = ("CC AORTIC ROOT INJECTION\n"
"CC CARDIOVERSION\n"
"CC COR ANG BYPASS W/LHC\n"
"CC COR ANG BYPASS W/R-LHC\n"
"CC COR ANGIO BYPASS\n"
"CC COR ANGIO W/LHC\n"
"CC COR ANGIO W/R-LHC\n"
"CC COR ANGIO W/RHC\n"
"CC CORONARY ANGIO\n"
"CC CORONARY ANGIO, CC COR ANGIO W/LHC\n"
"CC DUAL LEAD ONLY, INSERT\n"
"CC HEART CATH LEFT HEART\n"
"CC HEART CATH LEFT HEART, CC HEART CATH R+L ADULT\n"
"CC HEART CATH R+L ADULT\n"
"CC ICD DUAL CHAMBER\n"
"CC ICD GEN REMOVE\n"
"CC ICD GEN REP MULT LEAD\n"
"CC ICD GEN REPLACE\n"
"CC ICD INS W/LEADS\n"
"CC ICD LEAD TEST ONLY\n"
"CC INTRACARDIAC EP 3D MAP\n"
"CC IVUS CORONARY\n"
"CC LHC FOR LV GRAM ONLY\n"
"CC LHC FOR LV GRAM ONLY, CC COR ANGIO W/LHC\n"
"CC PACE GEN REP DUAL LEAD\n"
"CC PACEMAKER ATR + VENT\n"
"CC PACEMAKER CHANGE DUAL\n"
"CC PACEMAKER CHANGE SINGL\n"
"CC PACEMAKER INSERT TEMP\n"
"CC PERICARDIOCENTISIS\n"
"CC PTLR CABG DES/PCI,SGL\n"
"CC RHC FOR LV GRAM ONLY\n"
"CC TRANS ESOPH ECHO/TEE\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")