package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*([\d;]+)\*`)
var str = `***01;01;283***;Póvoa do Vâle do Trigo;15315100 ***01;01;249***;Alcafaz;;;;;;;;;;;3750;011;AGADÃO ***01;01;2504***;Caselho;;;;;;;;;;;3750;012;AGADÃO _ "15" '' ghdhghg **AND IT CONTINUES**
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}