use strict;
my $str = '@wb_export
def SimpleFunction(jsonstr):
#global fd
#os.write(fd, "wb_pre\\n")
# Definition of Input and Output Parameters (name and type)
"""{"in": {"param":"string"}, "out": {"return":"string"}}"""
# /!\\ Do not edit here !
# Edit function SimpleFunctionImpl() in "common" part
import json,os,sys,datetime
inputData = json.loads(jsonstr)
try:
outputData = SimpleFunctionImpl(inputData["param"])
fd = os.open("../log/custom_success.log", os.O_APPEND|os.O_CREAT|os.O_RDWR)
os.write(fd, "%s In : %s / Out : %s\\n" % (datetime.datetime.now().strftime("[%Y-%m-%d %H:%M:%S.%f]"), jsonstr, json.dumps(outputData)))
os.close(fd)
return json.dumps(outputData)
except Exception as e:
fd = os.open("../log/custom_error.log", os.O_APPEND|os.O_CREAT|os.O_RDWR)
os.write(fd, "%s INTERNAL ERROR: Custom code uncatched exception in VCO::SimpleFunction().\\n\\tIn : %s\\n\\tMessage: %s\\n" % (datetime.datetime.now().strftime("[%Y-%m-%d %H:%M:%S.%f]"), jsonstr, str(e)))
os.close(fd)
return json.dumps({"error":"INTERNAL ERROR: Custom code uncatched exception in VCO::SimpleFunction.\\n\\tMessage: %s" % str(e)})
except:
fd = os.open("../log/custom_error.log", os.O_APPEND|os.O_CREAT|os.O_RDWR)
os.write(fd, "%s INTERNAL ERROR: Custom code uncatched system exception in VCO::SimpleFunction().\\n" % (datetime.datetime.now().strftime("[%Y-%m-%d %H:%M:%S.%f]")))
os.close(fd)
return json.dumps({"error":"INTERNAL ERROR: Custom code uncatched system exception in VCO::SimpleFunction()."})
# End of SimpleFunction - VCO WB Custom Code Editor
@wb_export
def SimpleFunction2(jsonstr):
#global fd
#os.write(fd, "wb_pre\\n")
# Definition of Input and Output Parameters (name and type)
"""{"in": {"param":"string"}, "out": {"return":"string"}}"""
# /!\\ Do not edit here !
# Edit function SimpleFunctionImpl() in "common" part
return {"return": "OK2"}
';
my $regex = qr/^[\s]*@wb_export[\s]+def ([\w]+)\(jsonstr\):[\s\S]*?"""({"in":.*)"""([\s\S]*?)((@|$)[\s\S]*)$/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}