re = /^\$ml\$(?=([^$]*\$){2}[^$]*$)[a-fA-F0-9$]{1,200}$/
str = '$ml$35460$93a94bd24b5de64d79a5e49fa372827e739f4d7b6975c752c9a0ff1e5cf72e05$752351df64dd2ce9dc9c64a72ad91de6581a15c19176266b44d98919dfa81f0f96cbcb20a1ffb400718c20382030f637892f776627d34e021bad4f81b7de8222'
# Print the match result
str.match(re) do |match|
puts match.to_s
end