using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{""query"":""([^""]*|$)";
string input = @"{""query"":""things to do"",""prefilteredchannel"":""gpse
{""query"":""las vegas"",""prefilteredchannel"":""gpsea
{""query"":""airport parking";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}