#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?-s)Charge Tip(?=.*-V)|(?!\A)\G.*\K-V"
Local $sString = "Lorem ipsum dolor sit -V amet, consectetuer adipiscing elit. " & @CRLF & _
"Aenean commodo ligula Charge Tip eget dolor. Aenean massa. " & @CRLF & _
"Cum sociis natoque penatibus et magnis dis parturient montes." & @CRLF & _
"Nascetur ridiculus Charge Tip mus. Donec quam felis,-Vultricies nec." & @CRLF & _
"Pellentesque eu, pretium quis, sem. Nulla consequat massa." & @CRLF & _
"Quis enim. DonecCharge Tippede justo, fringilla vel, aliquet nec.-V" & @CRLF & _
"Vulputate eget, arcu. In enim justo, rhoncus ut." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")