$re = '/(.)(?=(?!\1).)/m';
$str = 'CEEEETTEEEEGGGCCBCTTBHHHHHCCEEEEEEEEETTEETT
';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;