use strict;
my $str = '1ORAND2
2
1 OR 2 OR OR 15 15 15 AND 6
1 OR (9 AND OR3)
1 OR ( 2 AND 3) AND 2
( 2 2OR3) AND 1
(12AND13 AND1)OR(4 AND5)
((2AND3 AND 1)OR(4AND5))AND OR 6';
my $regex = qr/^[^\)][0-9 \((AND|OR)]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}