$re = '/(?<dayname>[A-Za-z]{3})\s(?<month>[A-Za-z]{3})\s(?<dayofmonth>\d{2})\s(?<hour>\d{2}):(?<minutes>\d{2}):(?<seconds>\d{2})(?:\.(?<milliseconds>\d*))?\s(?<year>\d{4})/i';
$str = 'Wed Jun 01 20:05:21.12345 2016';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);