import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\:]+\\:(?<field1>[^\\|]*)\\|(?<field2>[^\\|]*)\\|(?<field3>[^\\|]*)\\|(?<field4>[^\\|]*)\\|(?<field5>[^\\|]*)\\|(?<field6>[^\\|]*)\\|(?<field7>[^\\|]*)\\|(?<field8>[^\\|]*)\\|(?<field9>[^\\|]*)\\|(?<field10>[^\\|]*)\\|(?<field11>[^\\|]*)\\|(?<field12>[^\\|]*)\\|(?<field13>[^\\|]*)";
final String string = "- Promotion Created, Coupon Settings For PromoCode=121509PromoId=3550966 : 17429150|Gillette|111082|9999999|Save $5.00 on Gillette|Save $5.00 on ONE Gillette Fusion ProShield|2016-05-29T07:00:00Z|2016-07-02T07:00:00Z|2016-07-02T07:00:00Z||811000474001215093500110100|RMS|[047400656048, 047400656055, 047400656062, 047400656079, 047400656109, 047400656116]|[]||RetailerBanners : [Brookshire]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}